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1 Overview 
Sprite Clone is the industry leading solution for deploying mobile devices in the enterprise 

environment.  Using Sprite Mobile’s award winning backup engine, Clone is able to take complete 

images of a device and storage card and to replicate it onto as many devices as you need.  With a 

powerful command structure, Clone is also able to perform time consuming individual device 

configurations, such as configuring unique device identities and network settings. 

This guide will take you through the full functionality of Clone from your simple first device clone, to 

the techniques needed to roll out an image to thousands of devices. 
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2 Installation 
Before installation, make sure you have met the installation requirements below. 

2.1 Requirements 
Below are the minimum hard and software requirements for both your PC and mobile devices. 

2.1.1 PC Requirements 

 Operating System – Windows XP and above 

 Software – Active Sync 4.0 and Internet Explorer 6.0 

2.1.2 Mobile Device Requirements 

 Clone operates on mobile devices running StrongARM or XScale processors.  SH3 or MIPS 

processors are not supported.  PocketPC and SmartPhones must be running Windows 

Mobile 5.0 or higher. 

To install Sprite Clone, simply double click on ‘SetupSpriteClone_Retail_version.exe’ and follow the 

on screen instructions. 

3 Licensing Clone 
When you purchased Clone you will have been supplied with a license file (SCLicense.txt).  You 

must install this file to enable deployment across multiple devices.  The quantity of licenses you 

purchased will determine how many devices you can deploy a single image to.  i.e. A 100 license 

pack will allow you to roll out the same image to 100 devices. 

To install the license simply copy it to the folder where Clone is installed.  By default this is 

C:/Program Files/Sprite Software/Sprite Clone.  The license will be installed when you 

restart Clone.  You can check the license has installed correctly by selecting Help>About from the 

Clone menu. 
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4 Quick Start Guide 
This section will take you through the steps to perform your first clone.  These steps will not be 

explained in detail, as this will be done in the relevant sections, but are designed to be followed as a 

quick introduction to the basic procedure. 

4.1 Performing Your First Clone 
Select a device to become the master image for your clone and ensure that it can connect to your PC 

through ActiveSync.  Ensure the master device has a storage card inserted. 

1. Start Sprite Clone and select File>Save to Card. 

2. On the dialog that pops up, select Storage Card and click OK.  The Clone Device Agent will be 

installed to your master device.  A dialog will appear when this is complete, click OK to 

dismiss it. 

3. Remove the storage card from your device and reinsert it.  After a few seconds the agent will 

start and a backup image of your device will be taken.  During this process your device will 

reboot twice.  Do not try and use your device during this time as you may corrupt the image 

that Clone takes. 

4. After the second reboot a dialog will appear to indicate that the imaging process is 

complete. 

5. To install the image onto a target device simply insert the storage card into the target.  The 

clone agent will launch and begin deploying the image from your master device.  

Congratulations, you have just created  your first clone.  For full details on all the options 

available to you during the imaging and deployment process, see the relevant sections. 
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5 Creating a Backup Image 
For a brief summary on how to create a clone of your device see the Quick Start Guide (page 6). 

Sprite Clone consists of two components, one for the PC (Sprite Clone Manager) and one for the 

device (Clone Agent).  Any changes you make to the Sprite Clone Manager must be saved to the 

Clone Agent to take effect.  To do this, ensure your master device has a storage card installed, and 

connect it to your PC.  If you can see your device in Windows Explorer then you are ready to 

proceed.  Start the Sprite Clone Manager and select File>Save to Card.  Select your storage card 

from the list that appears and click OK.  The Clone Agent will then be installed to a folder called 

‘2577’ on the storage card.  The dialog below will be displayed to show the progress.  Do not unplug 

your device during this time, as you may interrupt the installation process. 

 

Figure 1 – Clone Agent loading progress dialog 

Tip: If you do not have your master device present you can select File>Save to Directory and the 
Clone Agent will be installed to a storage card of your choice, using a storage card reader. 

 

Another dialog will appear when installation is complete. 

 

Figure 2 - Clone Agent installation complete dialog 

To create an image of your master device all you have to do is remove your storage card and then 

insert it again.  After a few seconds the Clone Agent will start and the imaging process will begin.  

Your device reboot twice during this time.  Please ensure that you do not use the device during the 

imaging process as this may corrupt the image that Clone takes. 

If you require more than a simple image to be made, then Sprite Clone has a number of ways in 

which you can customize the way your image is created.  These customizations can be found on the 

‘Backup Settings’ and ‘Backup Commands’ tabs. 
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5.1 Backup Settings 
When selecting the Backup Settings tab, seven options are presented, as shown below.  All 

configuration options can be saved for reuse later on.  To do this, simply click the Save button, or 

select the ‘File’ menu and click ‘Save’. 

 

Figure 3 - Screenshot of Backup Settings 

When you make any changes to these options they will not become active until you save them to 

your Clone Agent, using File>Save to Card or File>Save to Directory.  The various options are 

explained in detail below. 

5.1.1 Perform Backup Automatically when Storage Card is Inserted 

By default, when a storage card containing the Clone Agent is inserted into your device it will look 

for an existing image in it’s directory.  If one cannot be found, then a backup image will be taken.  If 

you do not want this feature in effect, then un-tick this option. 

Tip: If you would like to start the Clone Agent manually, then click on 'Sprite Clone.exe' in 
the 2577 directory. 
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5.1.2 Compress Image 

When compression is enabled, the master image will take up less space on your storage card.  

However, this will also slightly increase the time needed both to create the image and to deploy it 

later.  If you have a large number of devices to deploy and storage space is not a problem, you may 

benefit from turning this option off. 

5.1.3 Exclude Storage Card Contents in the Image 

Not only does the clone agent take an image of your device, it also takes an image of your storage 

card (minus the agent directory).  The storage card contents will then be mirrored on the target 

device when you deploy.  If you do not want this feature in effect, then un-tick this option.. 

5.1.4 Display Notification Message After Backup 

Enable/disable the image completion message after a backup image is complete. 

5.1.5 Use Default Image Name 

By default the Clone Agent will place the master image into it’s own directory and give it a title of 

‘Clone_yyyy-mm-dd’.  If you would like to store the clone file in a user-designated directory, then un-

tick this option.  You can then enter another name for you image file in the ‘Image Path on Device’ 

textbox. 

Tip: A simple name, for example ‘Master Device Image’, will still be stored in the 2577.  
However you can put any valid device path you like, e.g. ‘/Storage Card/Image 
Files/Master Device Image’, and the image file will be stored in that location. 

 

5.1.6 Include Network Provisioning Files to the Deployment Folder 

Sprite Clone allows you to capture existing Wi-Fi and GPRS settings from your master device and to 

deploy them to your target devices.  The steps below will guide you through the process to capture 

and restore Wi-Fi settings; however the process for GPRS is the same. 

Place a tick next to ‘Include Network Provisioning Files to the Deployment Folder’ and then select 

the ‘File’ menu and click ‘Save to Card’.  When the transfer has is complete the 2577 directory on 

the storage card will contain three additional files, ‘ProcessConfigXML.exe’, ‘Wi-FiQuery.xml’ 

and ‘CM_GPRSEntriesQuery.xml’.  Rename ‘Wi-FiQuery.xml’ to 

‘ProcessConfigXMLIn.xml’, and then run ‘ProcessConfigXML.exe’ from your device. 

Tip: To run ProcessConfigXML.exe on your device select .Start>Programs>File Explorer.  
Locate your 2577 directory and tap on ProcessConfigXML. 

 

A new file will be created in the 2577 directory call ‘ProcessConfigXMLOut.xml’.  This file will 

contain all the Wi-Fi settings that could be found on your master device.  This output file must now 

become the input file for deployment.  To do this, delete ‘ProcessConfigXMLIn.xml’ and rename 

‘ProcessConfigXMLOut.xml’ to ‘ProcessConfigXMLIn.xml’. 

To deploy the Wi-Fi settings automatically you should make use of the ‘Run Once On Startup After 

Restore’ feature on the ‘Restore Commands tab’.  Right click on ‘Run Once On Startup After Restore’ 

and select ‘Add Program to Run’.  In the textbox that appears enter the path to 

‘ProcessConfigXML.exe’ on your device.  By default this will be ‘\Storage 
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Card\2577\ProcessConfigXML.exe’.  Save the changes to the Clone Agent by selecting the ‘File’ 

menu and clicking ‘Save to Card’ and you’re done.  When a restore completes 

‘ProcessConfigXML.exe’ will then run and restore the device Wi-Fi settings. 

As mentioned previously, to deploy your GPRS settings, simply complete the same set of actions, but 

with the ‘CM_GPRSEntriesQuery.xml’ file instead of ‘Wi-FiQuery.xml’.  To find out more about 

the restore commands, see Restore Commands. 

5.2 Backup Commands 
The commands below allow you to perform fully customizable actions to be complete both before 

and after the creation of your master image. 

 

Figure 4 - Screenshot of Backup Commands 

5.2.1 Pre-Backup 

Command entered here will run after the first reset, but before the master image is taken.  This 

means that any changes that occur will be included in the master image. 
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5.2.2 Post-Backup 

Post-Backup commands will occur immediately after the master image is created, but before the 

second reset. 

5.2.3 Run Once on Startup After Backup 

These commands will run after the second reset. 

For each command, you can either select to perform a simple file operation or to run a Windows 

Mobile compatible file of your choice.  To enter a new command right click on one of the command 

types mentioned above and select from the popup menu.  Commands are performed sequentially in 

the order they appear in your list. 

The file operations you can perform are detailed below. 

5.2.4 Copy File 

Enter source and destination paths for the file you wish to copy. 

5.2.5 Move File 

Enter source and destination paths for the file you wish to move. 

5.2.6 Delete File 

Enter the full path for the file you wish to delete. 

5.2.7 Create Directory 

Enter the full path for the directory you would like to create 

5.2.8 Delete Directory 

Enter the full path for the directory you would like to delete 

Tip: The directory deletion will only succeed if the directory is empty. 
 

To save these changes to the Clone Agent, select ‘Save to Card’ from the ‘File’ menu, or click the 

‘Save to Card’ button. 
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6 Restoring an Image 
For a brief summary on how to restore an image to a target device, see the Quick Start Guide (page 

6). 

By default Sprite Clone is designed to deploy the master image to a target device when a storage 

card containing the master image is inserted, or if a hard reset is performed on a device containing a 

storage card with a master image.  During the process the target device will be reset twice. 

Sprite Clone has a large selection of options available to you when it comes to deploying an image to 

your target devices.  These have been grouped together into five areas for easy navigation, and are 

detailed below. 

6.1 Restore Settings 
The basic options for deploying an image to your target devices are found here.  Each is explained in 

detail below. 

 

Figure 5 - Screenshot of Restore Settings 
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6.1.1 Perform Restore Automatically when Storage Card is Inserted of Device is Hard 

Reset 

When set, and if your storage card has a valid 2577 directory, the Clone Agent will look for a master 

image to restore.  If it finds one, the Clone Agent will immediately begin to restore that image to the 

device.  Additionally, if a storage card containing the Clone Agent is present in your device when it is 

hard reset, the Clone Agent will again perform a master image check and perform a restore.  If you 

do not want this feature in effect, then un-tick this option. 

Tip: If you would like to start the Clone Agent manually, then click on 'Sprite Clone.exe' in 
the 2577 directory. 

 

6.1.2 Only Restore Once Per Device Via Autorun (Create marker file on device) 

Every time the conditions of the previous option are met the Clone Agent will deploy the master 

image to your target device.  If you would only like this to occur once, select this option.  Any 

subsequent card insertions or device hard resets will not trigger the Agent to deploy. 

6.1.3 Display Notification Message After Restore 

After a successful image deployment, the Clone Agent will display a dialog informing you that the 

process is complete.  If you do not want this feature in effect, then un-tick this option. 

6.1.4 Use Default Image Name 

By default Agent will look for the master image inside it’s 2577 directory.  However, if you placed 

the image in another location during the backup process then un-tick this option and enter the name 

or path to the image in the ‘Image Path on Device’ textbox.  For more details on placing the master 

image in a customized location see the Use Default Image Name section (page 9). 

To save these changes to the Clone Agent, select ‘Save to Card’ from the ‘File’ menu, or click the 

‘Save to Card’ button. 

6.2 Restore Commands 
The following commands allow you to fully customize the actions to be completed both before and 

after the deployment of your master image. 
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Figure 6 - Screenshot of Restore Commands 

6.2.1 Pre-Restore 

Command entered here will run after the first reset, but before the master image restored. 

6.2.2 Post-Restore 

Post-Restore commands will occur immediately after the master image is restored, but before the 

second reset. 

6.2.3 Run Once on Startup After Restore 

These commands will run after the second reset. 

For each command, you can either select to perform a simple file operation or to run a Windows 

Mobile compatible file of your choice.  To enter a new command right click on one of the command 

types mentioned above and select from the popup menu.  Commands are performed sequentially in 

the order they appear in your list. 

The file operations you can perform are detailed below. 

6.2.4 Copy File 

Enter source and destination paths for the file you wish to copy. 
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6.2.5 Move File 

Enter source and destination paths for the file you wish to move. 

6.2.6 Delete File 

Enter the full path for the file you wish to delete. 

6.2.7 Create Directory 

Enter the full path for the directory you would like to create 

6.2.8 Delete Directory 

Enter the full path for the directory you would like to delete 

Tip: The directory deletion will only succeed if the directory is empty. 
 

To save these changes to the Clone Agent, select ‘Save to Card’ from the ‘File’ menu, or click the 

‘Save to Card’ button. 

6.3 Restore Settings Customized Per Device 
Sprite Clone has the ability to customize items on the target device.  If you are using the same 

master image on multiple devices then you can also instruct the Clone Agent to add a unique 

number (known as a substitution value) to the item it is restoring.  The values that can be 

customized are broken down into the five areas below. 
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Figure 7 - Screenshot of Restore Settings Customized Per Device 

6.3.1 Identification 

Here you can give the target device a name and description.  If you would like to give each device a 

unique name then you can make use of the Clone Agent’s Substitution Value function.  This will add 

a unique number to the entry at a point you decide.  To insert a Substitution Value place the cursor 

where you would like the value to occur and select the ‘Edit’ menu, then click ‘Insert Sequence’.  For 

example if you selected a device name of ‘Sales Device [seq]’, and then used the same storage card 

to deploy on multiple devices, the devices would be named ‘Sales Device 1’, ‘Sales Device 2’, Sales 

Device 3’ etc. 

6.3.2 Network Adaptors 

The Clone Agent can also fully customize all the network adaptors on the target device.  The first 

step in customizing these values is to import the existing adaptors.  To do this select the ‘Import’ 

menu, then click ‘Per Device Setting’ and finally ‘From Device’.  The Sprite Clone Manager will then 

collect details of all the network adaptors it can find on the attached device.  Once this is complete, 

select the adaptor you would like to customize.  Then simply edit the values required as given below. 
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6.3.2.1 DHCP Enabled 

If you would like the adaptor to gain it’s setting from the network, select this checkbox.  If selected, 

you will not have to enter values for the remaining items. 

6.3.2.2 First IP Address 

The Clone Agent can assign unique IP addresses to each target device the same master image is used 

on.  This value dictates the lower end of the range of IP addresses to use. 

6.3.2.3 Last IP Address 

Used in conjunction with First IP Address this value dictates the upper limit of an IP range to use.  

Tip: If you only assign an IP range of five and then use try to deploy the image to a sixth device, 
the Agent will generate an error on deployment and the IP address will not be assigned. 

 

6.3.2.4 Subnet Mask 

Dictates the subnet mask to deploy. 

6.3.2.5 Default Gateway 

Dictates the default gateway to deploy. 

6.3.3 Registry Values 

The Clone Agent can add new registry values to the target device during deployment.  To add a new 

value, right click on ‘Registry Values’ and select ‘Add Registry Value’.  The registry value is defined by 

the following entries. 

6.3.3.1 Key Root 

Select from the list of key roots given, or enter your own. 

6.3.3.2 Key Name 

Enter the path of the key name to create.  For example, setting Key Root to ‘HKEY_CURRENT_USER’ 

and the Key Name to ‘test\name’ would create a key name of ‘HKEY_CURRENT_USER\test\name’. 

6.3.3.3 Value Name 

Enter the value name for you registry value. 

6.3.3.4 Value Type 

Select the type of value to create from the drop down list.  This will populate the textbox for you. 

6.3.3.5 Edit Mode 

Select how you want to input the registry value.  You can select from Normal, Multi String and 

Binary. 

6.3.3.6 Value 

Finally enter the value to enter for this registry value.  You may use the Substitution Values in this 

field.  To enter a Substitution Value select the ‘Edit’ menu and click ‘Insert Sequence’. 

6.3.4 Registry Value Deletions 

The Clone agent can also be instructed to delete registry values after the master image has been 

deployed.  To add a value to delete, right click on ‘Registry Value Deletions’ and click ‘Add Registry 
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Value’.  Then simply enter the values as required, following the same principles as for Registry 

Values above. 

6.3.5 Substitution Values 

Some of the customizations in this section allow you to enter a unique value whenever the same 

image is deployed to multiple devices.  By default the unique value is a number starting at 0, 

however you can change that value here to whatever number is needed.  This value will then 

increase by one whenever the Clone Agent is deployed. 

Tip: The Substitution Value must be a whole number. 
 

6.4 Registry Entries to Retain 
When you deploy a master image, the registry is returned to its factory state, before the image is 

deployed.  If you would like specific registry keys or values to remain untouched during the 

deployment, then enter their details here. 

6.4.1 Registry Keys 

To retain a specific key, right click on ‘Registry Keys’ and select ‘Add Registry Key’.  Select the 

desired root key from the drop down list and then enter the key name in the textbox provided.  For 

example selecting a root key of ‘HKEY_CURRENT_USER’ and a Key Name of ‘test\name’ would 

preserve the key ‘HKEY_CURRENT_USER\test\name’. 

6.4.2 Registry Values 

Retaining a specific registry value works in the same way as for Registry Keys.  To enter a value right 

click on ‘Registry Values’ and select ‘Add Registry Value’.  Then simply select the desired root key 

from the drop down list and enter the key name and value in the textboxes provided. 

6.4.3 Restoring Previously Entered Values 

When you save the Agent to it’s 2577 directory, these registry settings are stored in a file called 

‘RetainRegIn.txt’.  If you would like to retrieve them again, simply select the ‘Import’ menu and click 

‘Retain Registry Settings’.  A dialog will appear allowing you to select the file; click ‘Open’ and your 

settings will appear again. 

To save these changes to the Clone Agent, select ‘Save to Card’ from the ‘File’ menu, or click the 

‘Save to Card’ button. 

6.5 Scheduled Restore Commands 
The Clone Agent can be set to restore the master image to your target device at specific intervals.  

This can be extremely useful if you need to restore your device to a known state, in order to undo 

any changes made by a user. 
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Figure 8 - Screenshot of Scheduled Restore Settings 

6.5.1 Enable Scheduled Restores 

If you enable this option, you will be required to enter a time schedule.  This can be any time up to 

24 hours 60 minutes.  The time entered will designate the time to elapse once a previous 

deployment has completed until a new deployment must start. 

6.5.2 Password Required to Cancel Restore 

To prevent a user from cancelling a restore, you can request a password to be entered before a 

cancel is processed.  By enabling the option, you must enter a value in the ‘Password’ textbox.  The 

password you select may be as strong or as weak as you require. 

To save these changes to the Clone Agent, select ‘Save to Card’ from the ‘File’ menu, or click the 

‘Save to Card’ button. 


